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Introduction

Overview

Exatech's Xtimelog is a windows 3.x application for personal time usage recording. It is written for
the professional who turns on his or her personal computer as the first thing on reaching the 
office in the morning.

Xtimelog maintains a time usage Database. This database is useful in constructing monthly 
activity reports, filling out time cards, or simply reviewing ones own activity record.
You add projects to your Xtimelog database by using the Add Project item in the Edit pull down 
menu. Then you add time usage data to your projects by Punching In and Punching Out.

You use the New item in the File menu to create a new empty database. Most of the time,  you 
will be using the same database. Therefore Xtimelog will open the database that you used last 
when it starts up. It knows to do this by reading the Xtimelog.ini file that it wrote into your windows
directory the last time you selected or created a database.

If Xtimelog can not find an Xtimelog.ini file, a dialog box will let you know and Xtimelog will start 
up without a database. You can then use either the New or Open items in the File menu to give 
Xtimelog a database to use.

Database

A database consists of a set of projects. Each project has a name and a set of work sessions. 
The List Box in the main window displays the names of the projects in the open database.
A work session has a start time and an ending time and an optional short comment identifying the
activity or purpose of that work session. If the Check Box in the main window is checked, 
Xtimelog will ask for this comment when you  Punch In and allow you to edit it again when you 
Punch Out.

An Xtimelog database is kept in a file with the default  extension .tim. For instance, you might 
choose to keep a database of projects in a file named C:\xtimelog\hobbies.tim. You could also 
have another database of projects in c:\xtimelog\work.tim.

The name of the database file that is open is displayed in the title bar of the main window.

Product Registration

This program is copyrighted by Exatech Corporation. Exatech's copyright is protected by the 
United States copyright laws and international treaty provisions.
A single user/single CPU license may be obtained from Exatech Corporation for  $49.95 plus a 
$5.00 shipping and handling fee. The License Registration item on the Help menu will give you a 
way to have the program print out an order form. Please send your license registration fee to:

Exatech Corporation
6547 N. Academy Blvd. Suite 527
Colorado Springs, Colorado 809l8

Please include your name, address and telephone number with your order. Upon receipt of your 
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order, Exatech will provide you with a diskette containing the latest version of the program, a 
registration number that will also serve to deactivate the initial Registration Information dialog box
,a telephone support number and a copy of the license agreement.

EXATECH CORPORATION DISCLAIMS ALL WARRANTIES WITH RESPECT TO THIS 
SOFTWARE. THIS SOFTWARE IS PROVIDED FOR USE AS IS WITHOUT WARRANTY OF 
ANY KIND EITHER EXPRESS OR IMPLIED. ANY USE OF THIS SOFTWARE IS AT YOUR OWN
RISK. EXATECH CORPORATION DISCLAIMS ALL WARRANTIES OF MERCHANTABILITY 
AND FITNESS FOR A PARTICULAR USE.

No license to use this software for other than demonstration purposes exists until the registration 
fee is paid to Exatech Corporation.
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Main Window Buttons and Controls

Comment Check Box

Above the Punch In Button in the main window, there is a check box labeled, "Comment". If this 
box has an X in it when you Punch In, you will be prompted for a short comment that describes 
the purpose of your work session. Subsequently, when you Punch Out, you will be given the 
opportunity to revise the comment that you previously entered. The comment that is entered will 
appear in several of the reports that can be generated from the Report Menu.

If you do not want to enter this comment, click the mouse button on the X to make it go away. 
Alternatively, you can press the tab key until the check box is highlighted. Then press the space 
bar to achieve the same result.

If the check box does not have an X and you wish to enter comments describing your work 
sessions, click the box with the mouse button or tab to it and press the spacebar to turn the X 
back on.

Main Window List Box

There is a list box in the main window that contains the names of the projects in the open 
database. It is to the left of the column of buttons in the main window.

One selects a project in the list box by clicking on it with the left mouse button or by tabbing to the
list box and using the up and down arrow keys. Double clicking the left mouse button on a project 
is equivalent to selecting that project and clicking on the Punch In button. So don't double click to
establish the selected project unless you also want to punch in.

One adds new projects to the Database and therefore to this list box by using the Add Project 
item in the Edit menu.

Punch In Button

There is a button in the main window labeled Punch In. Clicking the left mouse button on this 
button causes a new work session to be added to the selected project ( see Main Window List 
for a description of the selected project). The start or punch in time for the work session is the 
system time when the button is clicked.

One can also punch in by double clicking on a project in the list box, or by tabbing to the Punch 
In button and pressing the enter key.

If the Comment Check Box is  checked, you will be prompted for a short descriptive comment 
that applies to the work session.

When you punch in, black smoke will appear above the chimney in the icon in the upper right 
hand corner of the main window indicating that the database has been updated with an open 
session.

If you wish, you are now free to quit the program using the Quit button, the Exit item in the File 
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menu or the Close item in the control menu box. It is not necessary to quit the program. But 
many people will want to free up the system resources used by Xtimelog for use by other 
programs. You could also reduce Xtimelog to an icon as a reminder to Punch Out when the work 
session is complete.

If you are Punched In when you exit windows and Xtimelog is active, it will remind you that you 
might wish to punch out. This might be a reason to keep Xtimelog active and to establish a work 
routine of exiting windows before you turn off the computer.

Punch Out Button

The Punch Out Button appears below the  Punch In Button in the main window.  If the open 
Database has an open work session, clicking the left mouse button on the Punch Out Button 
ends the open session. The now completed session will be written to the database  and it will 
contain the system time at punch out as its ending time.

Punching out will stop the black smoke coming from the chimney in the icon in the upper right 
hand corner of the main window.

Status Button

The Status Button appears below the  Punch Out Button in the main window.  Activating this 
button causes a dialog box to appear. This dialog box will show several items that include:

     The present date and time from the system clock.
     The name of the open database if any.
     The name of the open database's file.
     The name of the selected project.
     Whether there is an open work session.

None of these items can be edited from the status dialog box. They are for your information only. 
You should activate the Cancel button to dismiss this dialog.
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Pulldown Menu Items

File Menu

The File Menu is the first menu on the left hand side of the menu bar. It contains five menu items:

      New
      Open...
      SaveAs...
      Append...
      Exit

The items in this menu can be chosen with the mouse or by pressing the Alt key followed by the F
key followed by the underlined character in the menu item.

File Menu Item - New

The New item  in the File Menu creates a new Database of projects. 
Choosing this item causes a dialog box to appear that prompts you for a database name. This 
name will be used in the various Reports that can be generated from the database.
Immediately after entering the database name a file dialog box will appear in order for you to 
enter the name of the file to contain the new database.

The full path name of the new database file will appear in the title bar of the main window when 
you press the OK button in the file selection dialog box. The Project List Box should then be 
empty because a new database will not yet have any projects.

You can then use the Edit Menu's Add Project item to add projects to the new database.

File Menu Item - Open...

The Open... item  in the File menu reads in an existing Database of projects.

Choosing this item causes a file selection dialog box to appear that prompts you for the file name 
of the database file. The full path name of the new database file will appear in the title bar of the 
main window when you press the OK button in the file selection dialog box.

The Project List Box will then contain the names of the projects in the newly read database. 
If the new database contains an open work session the icon in the upper left corner of the main 
menu will be belching black smoke.
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File Menu Item -SaveAs...

The SaveAs... item in the File enu writes the Database of projects held by Xtimelog to a file that 
you are allowed to name.

Choosing this item causes a file selection dialog box to appear that prompts you for the file name 
of the new database file. The full path name of the new database file will appear in the title bar of 
the main window when you press the OK button in the file selection dialog box.

Using SaveAs... is equivalent to copying the Database file to a file with a different  name and 
then using the Open... item in the File menu to bring that new file's contents into Xtimelog as the 
database.

File Menu Item - Append...

The Append... item  in the File Menu allows you to append an existing Database to the open 
database.

Choosing this item causes a file dialog box to appear that prompts  you to specify the name of a 
project database  file to append to the open database. 

File Menu Item -Exit

The Exit item  in the File menu kills Xtimelog. It is equivalent to clicking on the Quit button in the 
main window or choosing the Close item in the Control Menu Box.

You are not prompted to save the Database  when you quit the program since the disk resident 
database is always updated whenever you  Punch In, Punch Out or Add Project....
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Edit Menu

The Edit Menu is the second menu on the left hand side of the menu bar. It contains four menu 
items:

      Add Project...
      Delete Selected Project...
      Edit Selected Project...
      Sort Selected Project's Sessions...
      Purge Data Earlier than Time...

The items in this menu can be chosen with the mouse or by pressing the Alt key followed by the 
"E" key followed by the underlined character in the menu item.

Edit Menu Item -Add Project

The Add Project... item  in the Edit menu allows you to add a new project to the open Database.
When you choose this menu item, a dialog box will appear to prompt you for the name of the new
project. When you enter the name and click on the OK button, the new project is added to the 
open database on disk and the project name is added to the list of projects displayed in the 
Project List Box.

Edit Menu Item -Delete Selected Project

The Delete Selected Project item  in the Edit menu allows you to delete a project from the open 
Database.  The project that will be deleted is the one selected in the  main window Project List 
Box. 

When you choose this menu item, a dialog box will appear to confirm that you want to delete the 
project. If you confirm by clicking the "Yes" button in the dialog box, the project and all of its 
sessions disappear from the open database's disk file and from the in memory representation of 
the database.

Occasionally you might go through this procedure and to your horror realize that it was a terrible 
mistake. You have one fallback. Don't do anything else. Quit Xtimelog. Then rename your 
database's ".tim" file to something you can remember in case of ultimate disaster. Then copy your
database's .bak file to become a new version of your database's .tim file.

Whenever a transaction is committed to disk, Xtimelog is copies the previous database to a ".bak"
file. See Data Security. We hope this saves you. But sometimes the best laid plans ... You know 
how it goes.
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Edit Menu Item -Edit Selected Project...

The Edit Selected Project... item  in the Edit menu allows you to edit  a project from the open 
Database.  The project that will be edited  is the one selected in the  main window Project List 
Box.

When you choose this menu item, a dialog box will appear. The first item at the top of this box, is 
the project name. You can change the project name by placing the cursor in the box containing 
the name and editing the name from the keyboard. When you choose the Quit button at the 
bottom of the dialog box, the project's name in the disk resident DatabaseDatabaseTopic is 
updated to reflect your editing.

There are a number of items grouped together and labeled with the word Session. This group 
allows you to edit the set of sessions owned by the project. The group has three text entry boxes 
and four push buttons.

The text entry boxes will contain data for one of the sessions or they will be blank if the project 
has no sessions. You can delete the session that is displayed by choosing the Delete button. You 
can add a new session by choosing the  Add New button. The session added in this case will 
have the Punch In and Punch Out times set to the system time. You can then edit these to be 
what you require.

You can move through the sessions owned by the project by choosing either the Back or the 
Next buttons.

In the case of the Punch In and Punch Out data, the date and time format expected by Xtimelog 
is the Windows default format. This default format is set by using the Windows Control Panel in 
your Program Manager's Main program group.

Edit Menu Item -Sort Selected Project's Sessions...

The Sort Selected Project's Sessions... item in the Edit menu allows you to sort the
sessions in a project according the start time of each session. It can happen that as a result of
appending different database files or as the result of editing sessions that project reports may
contain sessions in some arbitrary order. If this must be fixed, use this menu item.

Edit Menu Item -Purge Data Earlier Than Time...

The Purge Data Earlier Than Time... item  in the Edit menu allows you to remove logged time 
from the open Database. The dialog box that appears when you choose this menu item allows 
you to specify whether you wish to purge only the selected project or all projects.
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Report Menu

The Report Menu is the third menu on the left hand side of the menu bar. It contains four menu 
items:

      Today's Activity Report...
      Daily Report...
      Aggregate Report...
      Detailed Project Report...
      Dump Entire Database...

Each  item on this menu allows you to either send a report to the printer, to a text file or directly to
the screen using the clipboard viewer. In each case, the data  is similar. The text file output is 
convenient when you wish to save a permanent copy to import it into some other program such 
as a word processor or spreadsheet. There are two kinds of text formats available One is a 
simple tab separated format suitable for reading into a spreadsheet. The other is formatted for 
printing or reading into a text editor. Posting the reports to the clipboard provides a way to get the 
report into another program without writing a file.

When you choose an item from this menu, a dialog box will appear. You will be prompted as to 
whether you wish a printer output, a .txt file written or to have the report posted to the clipboard. If
you choose a text file, a file selection dialog box will appear in order for you to name the text file 
to be written. If you have chosen the formatted test file, the windows Notepad application will be 
launched to display the file you have written.

If you choose the clipboard, an instance of the Windows clipboard viewer will be launched that 
will display the report.

Report Menu Item - Today's Activity Report

This item on the Report Menu produces a report with the same information as the Aggregate 
Report. However, the time shown on this report only includes time logged during the present day. 
The time included is any time logged since midnight of the previous day until midnight of the 
present day.

Generating this report does not change the reporting period that may have been entered using 
the Set Reporting Period... item on the Options Menu.

Report Menu Item - Today's Activity Report

The Daily Report... item in the Report Menu produces a report that breaks out  the time spent on 
each project by day.

Generating this report does not change the reporting period that may have been entered using 
the Set Reporting Period... item on the Options Menu.

Report Menu Item -Aggregate Report...

The Aggregate Report... item in the Report menu produces a report that shows the total time for 
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each project and the sum for all projects in the open Database. This report suppresses the 
detailed punch in and punch out times for each session.

If you have defined a restricted reporting period by using the Set Reporting Period... item on the 
Options menu, then the report will only reflect time that was logged into the database during that 
restricted period.

Report Menu Item -Detailed Project Report...

The Detailed Project Report... item  in the Report menu produces a report that shows the 
details of the session activity for the project selected in the main window's Project  List Box. It 
also rolls up the total time for all the work sessions in that project.

If you have defined a restricted reporting period by using the Set Reporting Period... item on the 
Options menu, then the report will only reflect time that was logged into the database during that 
restricted period.

Report Menu Item -Dump Entire Database...

The Dump Entire Database... item  in the Report menu produces a report that contains the 
complete contents of the open Database.

If you have defined a restricted reporting period by using the Set Reporting Period... item on the 
Options menu, then the report will only reflect time that was logged into the database during that 
restricted period.

Options Menu

The Options Menu is the fourth menu from the left hand side of the menu bar. It contains three 
menu items:

      Set Icon Label Max. Length...
      Set Reporting Period...
      Set Reminder Interval...

Each  item on this menu allows you to set a default value that will affect the behavior of the 
Xtimelog.

Options Menu Item -Set Icon Label Max Length...

The Set Icon Label Max Length... item  in the Options menu allows you to control the number of 
characters in the label that appears with the Xtimelog icon when Xtimelog is minimized. The value
you enter is recorded in the Xtimelog.ini file in your windows directory. Consequently, the value 
will be remembered when Xtimelog is not running.
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Options Menu Item -Set Reporting Period...

The Set Reporting Period... item  in the Options menu allows you to define a time window that 
controls what part of the time logged in the Database will appear on reports and be reported to 
DDE clients. Setting a reporting period does not change the database. The reporting period is not
recorded in your Xtimelog.ini file and is forgotten when you quit Xtimelog.

Besides the normal OK and Cancel buttons, this dialog box contains five other push buttons. The 
one labeled, "Now" will cause the current system date and time to be placed into the boxes that 
determine the end of the new reporting period. The button labeled, "Year" will cause a date and 
time one year before the end of the new reporting period to be placed in the boxes that determine
the beginning of the new reporting period. The button labeled, "Month", "Week", and "Day" work 
similarly to the "Year" button with the obvious differences.

Options Menu Item -Set Reminder Interval...

Xtimelog's main window or Icon will periodically rise to the top of the stack of other active 
windows. The Set Reminder Interval... item in the Options menu allows you to set the time 
interval between these reminder interruptions. The value that you enter will be saved in your 
Xtimelog.ini file in your windows directory so that it will be remembered when Xtimelog is not 
running.

Help Menu

The Help Menu is on the right hand side of the menu bar. It contains three menu items:

      Using Xtimelog
      License Registration
      About Xtimelog

The first item is used to access the help system that contains essentiall the same information that
you are reading now. This can be done by selecting the menu item or pressing the F1 function 
key.

The second item provides information on how to obtain a license to use Xtimelog and the third 
item is the usual copyright banner.

Miscellaneous

Data Security

Whenever Xtimelog processes a transaction such as punching in, punching out or several others,
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it updates the disk resident database. Consequently, you should lose no data if your computer 
goes down for any reason.

If you should be so unlucky as to have lightning strike precisely at the time a transaction in being 
committed to disk the database could be left in an unknown state. But even in this case, all is not 
lost. When Xtimelog commits a transaction it first copies the database file. For instance if your 
database file was "projects.tim", Xtimelog first copies "projects.tim" to "projects.bak". Only then 
does it write out a new "projects.tim". So if lightning struck during the time Xtimelog was writing 
"projects.tim", you should have a valid database in "projects.bak" (except for the last transaction).
If the strike took place while the copy was taking place then Timelog would never have gotten to 
the point of overwriting "projects.tim" and it should also be valid (except for the last transaction).

Dynamic Data Exchange

Xtimelog can be a Dynamic Data Exchange (DDE) server. This means that it can provide data to 
other applications that are running under windows at the same time. 
The client application initiates a DDE conversation. The server application responds with 
requested data. This is a bit of an over simplification but it is adequate for our purposes here. For 
example Microsoft EXCEL can be a Xtimelog client. The only data items that Xtimelog is prepared
to supply as a server are the total time for each project in the open database.
For example, you can place a formula into an EXCEL cell that might look like the following:

 =XTIMELOG|'C:\work\projects.tim'!'Final Report'

EXCEL uses the "XTIMELOG" field from the formula to identify the server to ask for the data. So 
one or more instances of Xtimelog will have to be running. The second field, "C:\work\
projects.tim" is the "topic" on which EXCEL will request the server to open a conversation. So at 
least one of the running instances of Xtimelog will have to have opened a database file named C:\
work\projects.tim.
Finally, the item that EXCEL is requesting is the total hours worked on the project named, "Final 
Report". If the Xtimelog database has this project, it will add up the times of all the work sessions 
in this project and supply it to EXCEL. This number should then appear in the cell on the 
worksheet.

If any of the things required are not true then #NA will appear in the cell.
Other client applications will use this same three level scheme of service name, topic and item to 
request data. Their documentation will tell you how to use these same three items in their own 
context to get data from Xtimelog. There are also other ways for EXCEL  macros to initiate a DDE
conversation.

If you have used the Set Reporting Period... item on the Options menu to define a restricted 
reporting period, it is the total time logged during this restricted period that is reported to the DDE 
client. When you change the reporting period in Xtimelog, you will need to cause the client to 
update its links to get the new values to be transmitted to the client. For example with Microsoft 
Excel, you will need to use the "Links..." item on the "File" menu in order to do this.

Convenience Suggestions

Whenever you start Windows, programs that are in the Startup group in the Program Manager 
are automatically started. If you place Xtimelog in your Startup group, it will therefore be on the 
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screen at the beginning of work reminding you to record what you will be working on. 
Another suggestion is to not let your database files get too large. On every transaction, Xtimelog 
writes the entire database file. If that file contains the record of five years work , transactions 
could become very slow. In addition, you are risking five years data on each transaction. Perhaps 
a good idea is to start a new database at the beginning of every month and archive away the 
previous month's data.

It was once suggested that Xtimelog provide a menu command for writing out a single project or 
group of projects to an archive database file. Xtimelog does not now have this facility. The 
concept for Xtimelog was to make it very simple and not to add any features to complicate it that 
could be achieved in other ways. We could change our minds depending on customer demand. If 
you desire to do this, just copy the database file that contains the projects to be archived to 
another file, bring that new file into Xtimelog with the Open item on the File menu and then delete
the projects that you don't want with the Deleted Selected Project item on the Edit menu.

Exatech is always interested in hearing from users about new features that would increase the 
usefulness of Xtimelog.
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